use strict;
my $str = 'line = "This is a text.This is another text,it has no space after the comma."
';
my $regex = qr/(?<=[.,])(?=[^\s])/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";