using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[.,])(?=[^\s])";
string substitution = @" ";
string input = @"line = ""This is a text.This is another text,it has no space after the comma.""
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}