#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^My name is '([^']+)' and I live in (.+?)(?:$| capital$| capital and I like (.+?)(?: programming|$))"
Local $sString = "My name is 'Mark' and I live in Spain capital and I like computers programming" & @CRLF & _
"My name is 'Mark' and I live in Spain capital and I like computers" & @CRLF & _
"My name is 'Mark' and I live in Spain capital" & @CRLF & _
"My name is 'Mark' and I live in Spain"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")