import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^My name is '([^']+)' and I live in (.+?)(?:$| capital$| capital and I like (.+?)(?: programming|$))";
final String string = "My name is 'Mark' and I live in Spain capital and I like computers programming\n"
+ "My name is 'Mark' and I live in Spain capital and I like computers\n"
+ "My name is 'Mark' and I live in Spain capital\n"
+ "My name is 'Mark' and I live in Spain";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}