use strict;
my $str = 'My name is \'Mark\' and I live in Spain capital and I like computers programming
My name is \'Mark\' and I live in Spain capital and I like computers
My name is \'Mark\' and I live in Spain capital
My name is \'Mark\' and I live in Spain';
my $regex = qr/^My name is '([^']+)' and I live in (.+?)(?:$| capital$| capital and I like (.+?)(?: programming|$))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}