$re = '/^My name is \'([^\']+)\' and I live in (.+?)(?:$| capital$| capital and I like (.+?)(?: programming|$))/m';
$str = 'My name is \'Mark\' and I live in Spain capital and I like computers programming
My name is \'Mark\' and I live in Spain capital and I like computers
My name is \'Mark\' and I live in Spain capital
My name is \'Mark\' and I live in Spain';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);