#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^\.\w{1,4}$"
Local $sString = "" & @CRLF & _
". Mini MAGAZZINI - 2022-02-25 - FT MM9 000000123" & @CRLF & _
".notarealextension" & @CRLF & _
".-" & @CRLF & _
".pdf" & @CRLF & _
".html" & @CRLF & _
".1" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")