// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^\.\w{1,4}$").unwrap();
let string = "
. Mini MAGAZZINI - 2022-02-25 - FT MM9 000000123
.notarealextension
.-
.pdf
.html
.1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}