import re
regex = re.compile(r"^\.\w{1,4}$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("\n"
". Mini MAGAZZINI - 2022-02-25 - FT MM9 000000123\n"
".notarealextension\n"
".-\n"
".pdf\n"
".html\n"
".1\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")