re = /^\.\w{1,4}$/mi
str = '
. Mini MAGAZZINI - 2022-02-25 - FT MM9 000000123
.notarealextension
.-
.pdf
.html
.1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end