package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^\.\w{1,4}$`)
var str = `
. Mini MAGAZZINI - 2022-02-25 - FT MM9 000000123
.notarealextension
.-
.pdf
.html
.1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}