const regex = new RegExp('^\\.\\w{1,4}$', 'gmi')
const str = `
. Mini MAGAZZINI - 2022-02-25 - FT MM9 000000123
.notarealextension
.-
.pdf
.html
.1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}