#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d)\/y\d(?:;\1\/y\d){2}(?:;|$)"
Local $sString = "1/y1;1/y2;1/y3;1/y4;1/y6;2/b4;5/b5" & @CRLF & _
"1/y2;1/y3;1/y4*;2/y6;2/b4;8/b5" & @CRLF & _
"1/y2;1/y3;9/y4" & @CRLF & _
"1/y2;1/y3;1/y4*" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")