use strict;
my $str = '1/y1;1/y2;1/y3;1/y4;1/y6;2/b4;5/b5
1/y2;1/y3;1/y4*;2/y6;2/b4;8/b5
1/y2;1/y3;9/y4
1/y2;1/y3;1/y4*
';
my $regex = qr/^(\d)\/y\d(?:;\1\/y\d){2}(?:;|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}