$re = '/^(\d)\/y\d(?:;\1\/y\d){2}(?:;|$)/m';
$str = '1/y1;1/y2;1/y3;1/y4;1/y6;2/b4;5/b5
1/y2;1/y3;1/y4*;2/y6;2/b4;8/b5
1/y2;1/y3;9/y4
1/y2;1/y3;1/y4*
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);