import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d)\\/y\\d(?:;\\1\\/y\\d){2}(?:;|$)";
final String string = "1/y1;1/y2;1/y3;1/y4;1/y6;2/b4;5/b5\n"
+ "1/y2;1/y3;1/y4*;2/y6;2/b4;8/b5\n"
+ "1/y2;1/y3;9/y4\n"
+ "1/y2;1/y3;1/y4*\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}