using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d)\/y\d(?:;\1\/y\d){2}(?:;|$)";
string input = @"1/y1;1/y2;1/y3;1/y4;1/y6;2/b4;5/b5
1/y2;1/y3;1/y4*;2/y6;2/b4;8/b5
1/y2;1/y3;9/y4
1/y2;1/y3;1/y4*
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}