const regex = /^(\d)\/y\d(?:;\1\/y\d){2}(?:;|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d)\\\/y\\d(?:;\\1\\\/y\\d){2}(?:;|$)', 'gm')
const str = `1/y1;1/y2;1/y3;1/y4;1/y6;2/b4;5/b5
1/y2;1/y3;1/y4*;2/y6;2/b4;8/b5
1/y2;1/y3;9/y4
1/y2;1/y3;1/y4*
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}