#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?xm)" & @CRLF & _
"\b #boundary - begining of text" & @CRLF & _
"(?i)[a-z]+ #words without number(s) and ungreedy (?)" & @CRLF & _
"\b #boundary - end of text"
Local $sString = "abc" & @CRLF & _
"123" & @CRLF & _
"123anb" & @CRLF & _
"abc123" & @CRLF & _
"ba3" & @CRLF & _
"my age is 15" & @CRLF & _
"current year is 1980" & @CRLF & _
"$#%&#@#$%@!$$" & @CRLF & _
"MY country is INDIA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")