using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?xm)
\b #boundary - begining of text
(?i)[a-z]+ #words without number(s) and ungreedy (?)
\b #boundary - end of text";
string input = @"abc
123
123anb
abc123
ba3
my age is 15
current year is 1980
$#%&#@#$%@!$$
MY country is INDIA";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}