// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?xm)
\b #boundary - begining of text
(?i)[a-z]+ #words without number(s) and ungreedy (?)
\b #boundary - end of text").unwrap();
let string = "abc
123
123anb
abc123
ba3
my age is 15
current year is 1980
$#%&#@#$%@!$$
MY country is INDIA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}