re = /(?xm)
\b #boundary - begining of text
(?i)[a-z]+ #words without number(s) and ungreedy (?)
\b #boundary - end of text/m
str = 'abc
123
123anb
abc123
ba3
my age is 15
current year is 1980
$#%&#@#$%@!$$
MY country is INDIA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end