import re
regex = re.compile((r"(?xm)\n"
r"\b #boundary - begining of text\n"
r"(?i)[a-z]+ #words without number(s) and ungreedy (?)\n"
r"\b #boundary - end of text"), flags=re.MULTILINE)
test_str = ("abc\n"
"123\n"
"123anb\n"
"abc123\n"
"ba3\n"
"my age is 15\n"
"current year is 1980\n"
"$#%&#@#$%@!$$\n"
"MY country is INDIA")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")