use strict;
my $str = 'abc
123
123anb
abc123
ba3
my age is 15
current year is 1980
$#%&#@#$%@!$$
MY country is INDIA';
my $regex = qr/(?xm)
\b #boundary - begining of text
(?i)[a-z]+ #words without number(s) and ungreedy (?)
\b #boundary - end of text/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}