#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+(?!.*\d+)"
Local $sString = "Some101String123_0001.ext" & @CRLF & _
"Some101String123_1001.ext" & @CRLF & _
"Some101String10001.ext" & @CRLF & _
"SomeString1001" & @CRLF & _
"SomeString001.ext" & @CRLF & _
"Some101String123_nonsense.ext"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")