using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(?!.*\d+)";
string input = @"Some101String123_0001.ext
Some101String123_1001.ext
Some101String10001.ext
SomeString1001
SomeString001.ext
Some101String123_nonsense.ext";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}