$re = '/\d+(?!.*\d+)/m';
$str = 'Some101String123_0001.ext
Some101String123_1001.ext
Some101String10001.ext
SomeString1001
SomeString001.ext
Some101String123_nonsense.ext';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);