const regex = /\d+(?!.*\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+(?!.*\\d+)', 'gm')
const str = `Some101String123_0001.ext
Some101String123_1001.ext
Some101String10001.ext
SomeString1001
SomeString001.ext
Some101String123_nonsense.ext`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}