import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(?!.*\\d+)";
final String string = "Some101String123_0001.ext\n"
+ "Some101String123_1001.ext\n"
+ "Some101String10001.ext\n"
+ "SomeString1001\n"
+ "SomeString001.ext\n"
+ "Some101String123_nonsense.ext";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}