re = /\d+(?!.*\d+)/m
str = 'Some101String123_0001.ext
Some101String123_1001.ext
Some101String10001.ext
SomeString1001
SomeString001.ext
Some101String123_nonsense.ext'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end