using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[1-9](([0-9]{0,2}(\.[0-9]{3})*)|[0-9]*)$";
string input = @"---- válidos
1
12
123
1.100
123.123
2.321.234.556.654
---- válidos sem o ponto separando os milhares (caso seja aceito)
12345
1100
---- inválidos
1.1
1.2345
0
012
....";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}