// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[1-9](([0-9]{0,2}(\.[0-9]{3})*)|[0-9]*)$").unwrap();
let string = "---- válidos
1
12
123
1.100
123.123
2.321.234.556.654
---- válidos sem o ponto separando os milhares (caso seja aceito)
12345
1100
---- inválidos
1.1
1.2345
0
012
....";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}