re = /^[1-9](([0-9]{0,2}(\.[0-9]{3})*)|[0-9]*)$/m
str = '---- válidos
1
12
123
1.100
123.123
2.321.234.556.654
---- válidos sem o ponto separando os milhares (caso seja aceito)
12345
1100
---- inválidos
1.1
1.2345
0
012
....'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end