import re
regex = re.compile(r"^[1-9](([0-9]{0,2}(\.[0-9]{3})*)|[0-9]*)$", flags=re.MULTILINE)
test_str = ("---- válidos\n"
"1\n"
"12\n"
"123\n"
"1.100\n"
"123.123\n"
"2.321.234.556.654\n"
"---- válidos sem o ponto separando os milhares (caso seja aceito)\n"
"12345\n"
"1100\n"
"---- inválidos\n"
"1.1\n"
"1.2345\n"
"0\n"
"012\n"
"....")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")