use strict;
my $str = '---- válidos
1
12
123
1.100
123.123
2.321.234.556.654
---- válidos sem o ponto separando os milhares (caso seja aceito)
12345
1100
---- inválidos
1.1
1.2345
0
012
....';
my $regex = qr/^[1-9](([0-9]{0,2}(\.[0-9]{3})*)|[0-9]*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}