import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:,|^)OU=[^,]+(?=.*?,OU=([^,]+)).*";
final String string = "CN=John Mayor,OU=Users,OU=NA,OU=Local,DC=domain,DC=application,DC=com\n\n"
+ "CN=Annette,OU=Users,OU=CH,OU=Local,DC=domain,DC=application,DC=com\n\n"
+ "CN=Annette,OU=Users,LOLO=LOLO,OU=CH,OU=Local,DC=domain,DC=application\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}