$re = '/(?:,|^)OU=[^,]+(?=.*?,OU=([^,]+)).*/m';
$str = 'CN=John Mayor,OU=Users,OU=NA,OU=Local,DC=domain,DC=application,DC=com
CN=Annette,OU=Users,OU=CH,OU=Local,DC=domain,DC=application,DC=com
CN=Annette,OU=Users,LOLO=LOLO,OU=CH,OU=Local,DC=domain,DC=application
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);