re = /(?:,|^)OU=[^,]+(?=.*?,OU=([^,]+)).*/m
str = 'CN=John Mayor,OU=Users,OU=NA,OU=Local,DC=domain,DC=application,DC=com
CN=Annette,OU=Users,OU=CH,OU=Local,DC=domain,DC=application,DC=com
CN=Annette,OU=Users,LOLO=LOLO,OU=CH,OU=Local,DC=domain,DC=application
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end