const regex = /(?:,|^)OU=[^,]+(?=.*?,OU=([^,]+)).*/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:,|^)OU=[^,]+(?=.*?,OU=([^,]+)).*', 'mg')
const str = `CN=John Mayor,OU=Users,OU=NA,OU=Local,DC=domain,DC=application,DC=com
CN=Annette,OU=Users,OU=CH,OU=Local,DC=domain,DC=application,DC=com
CN=Annette,OU=Users,LOLO=LOLO,OU=CH,OU=Local,DC=domain,DC=application
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}