import Foundation
let pattern = #"(?:,|^)OU=[^,]+(?=.*?,OU=([^,]+)).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
CN=John Mayor,OU=Users,OU=NA,OU=Local,DC=domain,DC=application,DC=com
CN=Annette,OU=Users,OU=CH,OU=Local,DC=domain,DC=application,DC=com
CN=Annette,OU=Users,LOLO=LOLO,OU=CH,OU=Local,DC=domain,DC=application
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)