use strict;
my $str = 'CN=John Mayor,OU=Users,OU=NA,OU=Local,DC=domain,DC=application,DC=com
CN=Annette,OU=Users,OU=CH,OU=Local,DC=domain,DC=application,DC=com
CN=Annette,OU=Users,LOLO=LOLO,OU=CH,OU=Local,DC=domain,DC=application
';
my $regex = qr/(?:,|^)OU=[^,]+(?=.*?,OU=([^,]+)).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}