#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)<div[^>]*>\K(.+?)(?=<\/div>)"
Local $sString = "<div class="d-xl-none">" & @CRLF & _
" <button class="navbar-toggler" type="button" data-toggle="collapse" data-target="#navbar-top-menu">" & @CRLF & _
" <i class="icon-grid3"></i>" & @CRLF & _
" </button>" & @CRLF & _
"</div>" & @CRLF & _
"<div class='class_1'>" & @CRLF & _
" <span>test</span>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")