use strict;
my $str = '<div class="d-xl-none">
<button class="navbar-toggler" type="button" data-toggle="collapse" data-target="#navbar-top-menu">
<i class="icon-grid3"></i>
</button>
</div>
<div class=\'class_1\'>
<span>test</span>
</div>';
my $regex = qr/<div[^>]*>\K(.+?)(?=<\/div>)/sip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}