import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div[^>]*>\\K(.+?)(?=<\\/div>)";
final String string = "<div class=\"d-xl-none\">\n"
+ " <button class=\"navbar-toggler\" type=\"button\" data-toggle=\"collapse\" data-target=\"#navbar-top-menu\">\n"
+ " <i class=\"icon-grid3\"></i>\n"
+ " </button>\n"
+ "</div>\n"
+ "<div class='class_1'>\n"
+ " <span>test</span>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}