const regex = /<div[^>]*>\K(.+?)(?=<\/div>)/gsi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div[^>]*>\\K(.+?)(?=<\\\/div>)', 'gsi')
const str = `<div class="d-xl-none">
<button class="navbar-toggler" type="button" data-toggle="collapse" data-target="#navbar-top-menu">
<i class="icon-grid3"></i>
</button>
</div>
<div class='class_1'>
<span>test</span>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}