using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div[^>]*>\K(.+?)(?=<\/div>)";
string input = @"<div class=""d-xl-none"">
<button class=""navbar-toggler"" type=""button"" data-toggle=""collapse"" data-target=""#navbar-top-menu"">
<i class=""icon-grid3""></i>
</button>
</div>
<div class='class_1'>
<span>test</span>
</div>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}