re = /<div[^>]*>\K(.+?)(?=<\/div>)/i
str = '<div class="d-xl-none">
<button class="navbar-toggler" type="button" data-toggle="collapse" data-target="#navbar-top-menu">
<i class="icon-grid3"></i>
</button>
</div>
<div class=\'class_1\'>
<span>test</span>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end