#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mux)\b(?:[BS]/\.|R(?:D?\$|p))|" & @CRLF & _
"\b(?:[TN]T|[CJZ])\$|Дин\.|" & @CRLF & _
"\b(?:Bs|Ft|Gs|K[Mč]|Lek|B[Zr]|k[nr]|[PQLSR]|лв|ден|RM|MT|lei|zł|USD|GBP|EUR|JPY|CHF|SEK|DKK|NOK|SGD|HKD|AUD|TWD|NZD|CNY|KRW|INR|CAD|VEF|EGP|THB|IDR|PKR|MYR|PHP|MXN|VND|CZK|HUF|PLN|TRY|ZAR|ILS|ARS|CLP|BRL|RUB|QAR|AED|COP|PEN|CNH|KWD|SAR)\b|" & @CRLF & _
"\$[Ub]|" & @CRLF & _
"[\p{Sc}ƒ]"
Local $sString = "Lek" & @CRLF & _
"؋" & @CRLF & _
"$" & @CRLF & _
"ƒ" & @CRLF & _
"$" & @CRLF & _
"₼" & @CRLF & _
"$" & @CRLF & _
"$" & @CRLF & _
"Br" & @CRLF & _
"BZ$" & @CRLF & _
"$" & @CRLF & _
"$b" & @CRLF & _
"KM" & @CRLF & _
"P" & @CRLF & _
"лв" & @CRLF & _
"R$" & @CRLF & _
"$" & @CRLF & _
"៛" & @CRLF & _
"$" & @CRLF & _
"$" & @CRLF & _
"$" & @CRLF & _
"¥" & @CRLF & _
"$" & @CRLF & _
"₡" & @CRLF & _
"kn" & @CRLF & _
"₱" & @CRLF & _
"Kč" & @CRLF & _
"kr" & @CRLF & _
"RD$" & @CRLF & _
"$" & @CRLF & _
"£" & @CRLF & _
"$" & @CRLF & _
"€" & @CRLF & _
"£" & @CRLF & _
"$" & @CRLF & _
"¢" & @CRLF & _
"£" & @CRLF & _
"Q" & @CRLF & _
"£" & @CRLF & _
"$" & @CRLF & _
"L" & @CRLF & _
"$" & @CRLF & _
"Ft" & @CRLF & _
"kr" & @CRLF & _
"" & @CRLF & _
"Rp" & @CRLF & _
"﷼" & @CRLF & _
"£" & @CRLF & _
"₪" & @CRLF & _
"J$" & @CRLF & _
"¥" & @CRLF & _
"£" & @CRLF & _
"лв" & @CRLF & _
"₩" & @CRLF & _
"₩" & @CRLF & _
"лв" & @CRLF & _
"₭" & @CRLF & _
"£" & @CRLF & _
"$" & @CRLF & _
"ден" & @CRLF & _
"RM" & @CRLF & _
"₨" & @CRLF & _
"$" & @CRLF & _
"₮" & @CRLF & _
"MT" & @CRLF & _
"$" & @CRLF & _
"₨" & @CRLF & _
"ƒ" & @CRLF & _
"$" & @CRLF & _
"C$" & @CRLF & _
"₦" & @CRLF & _
"kr" & @CRLF & _
"﷼" & @CRLF & _
"₨" & @CRLF & _
"B/." & @CRLF & _
"Gs" & @CRLF & _
"S/." & @CRLF & _
"₱" & @CRLF & _
"zł" & @CRLF & _
"﷼" & @CRLF & _
"lei" & @CRLF & _
"₽" & @CRLF & _
"£" & @CRLF & _
"﷼" & @CRLF & _
"Дин." & @CRLF & _
"₨" & @CRLF & _
"$" & @CRLF & _
"$" & @CRLF & _
"S" & @CRLF & _
"R" & @CRLF & _
"₨" & @CRLF & _
"kr" & @CRLF & _
"CHF" & @CRLF & _
"$" & @CRLF & _
"£" & @CRLF & _
"NT$" & @CRLF & _
"฿" & @CRLF & _
"TT$" & @CRLF & _
"" & @CRLF & _
"$" & @CRLF & _
"₴" & @CRLF & _
"£" & @CRLF & _
"$" & @CRLF & _
"$U" & @CRLF & _
"лв" & @CRLF & _
"Bs" & @CRLF & _
"₫" & @CRLF & _
"﷼" & @CRLF & _
"Z$" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")