import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"""
\b(?:[BS]/\.|R(?:D?\$|p))|
\b(?:[TN]T|[CJZ])\$|Дин\.|
\b(?:Bs|Ft|Gs|K[Mč]|Lek|B[Zr]|k[nr]|[PQLSR]|лв|ден|RM|MT|lei|zł|USD|GBP|EUR|JPY|CHF|SEK|DKK|NOK|SGD|HKD|AUD|TWD|NZD|CNY|KRW|INR|CAD|VEF|EGP|THB|IDR|PKR|MYR|PHP|MXN|VND|CZK|HUF|PLN|TRY|ZAR|ILS|ARS|CLP|BRL|RUB|QAR|AED|COP|PEN|CNH|KWD|SAR)\b|
\$[Ub]|
[\p{Sc}ƒ]
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
Lek
؋
$
ƒ
$
₼
$
$
Br
BZ$
$
$b
KM
P
лв
R$
$
៛
$
$
$
¥
$
₡
kn
₱
Kč
kr
RD$
$
£
$
€
£
$
¢
£
Q
£
$
L
$
Ft
kr
Rp
﷼
£
₪
J$
¥
£
лв
₩
₩
лв
₭
£
$
ден
RM
₨
$
₮
MT
$
₨
ƒ
$
C$
₦
kr
﷼
₨
B/.
Gs
S/.
₱
zł
﷼
lei
₽
£
﷼
Дин.
₨
$
$
S
R
₨
kr
CHF
$
£
NT$
฿
TT$
$
₴
£
$
$U
лв
Bs
₫
﷼
Z$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)