import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:[BS]/\\.|R(?:D?\\$|p))|\n"
+ "\\b(?:[TN]T|[CJZ])\\$|Дин\\.|\n"
+ "\\b(?:Bs|Ft|Gs|K[Mč]|Lek|B[Zr]|k[nr]|[PQLSR]|лв|ден|RM|MT|lei|zł|USD|GBP|EUR|JPY|CHF|SEK|DKK|NOK|SGD|HKD|AUD|TWD|NZD|CNY|KRW|INR|CAD|VEF|EGP|THB|IDR|PKR|MYR|PHP|MXN|VND|CZK|HUF|PLN|TRY|ZAR|ILS|ARS|CLP|BRL|RUB|QAR|AED|COP|PEN|CNH|KWD|SAR)\\b|\n"
+ "\\$[Ub]|\n"
+ "[\\p{Sc}ƒ]";
final String string = "Lek\n"
+ "؋\n"
+ "$\n"
+ "ƒ\n"
+ "$\n"
+ "₼\n"
+ "$\n"
+ "$\n"
+ "Br\n"
+ "BZ$\n"
+ "$\n"
+ "$b\n"
+ "KM\n"
+ "P\n"
+ "лв\n"
+ "R$\n"
+ "$\n"
+ "៛\n"
+ "$\n"
+ "$\n"
+ "$\n"
+ "¥\n"
+ "$\n"
+ "₡\n"
+ "kn\n"
+ "₱\n"
+ "Kč\n"
+ "kr\n"
+ "RD$\n"
+ "$\n"
+ "£\n"
+ "$\n"
+ "€\n"
+ "£\n"
+ "$\n"
+ "¢\n"
+ "£\n"
+ "Q\n"
+ "£\n"
+ "$\n"
+ "L\n"
+ "$\n"
+ "Ft\n"
+ "kr\n\n"
+ "Rp\n"
+ "﷼\n"
+ "£\n"
+ "₪\n"
+ "J$\n"
+ "¥\n"
+ "£\n"
+ "лв\n"
+ "₩\n"
+ "₩\n"
+ "лв\n"
+ "₭\n"
+ "£\n"
+ "$\n"
+ "ден\n"
+ "RM\n"
+ "₨\n"
+ "$\n"
+ "₮\n"
+ "MT\n"
+ "$\n"
+ "₨\n"
+ "ƒ\n"
+ "$\n"
+ "C$\n"
+ "₦\n"
+ "kr\n"
+ "﷼\n"
+ "₨\n"
+ "B/.\n"
+ "Gs\n"
+ "S/.\n"
+ "₱\n"
+ "zł\n"
+ "﷼\n"
+ "lei\n"
+ "₽\n"
+ "£\n"
+ "﷼\n"
+ "Дин.\n"
+ "₨\n"
+ "$\n"
+ "$\n"
+ "S\n"
+ "R\n"
+ "₨\n"
+ "kr\n"
+ "CHF\n"
+ "$\n"
+ "£\n"
+ "NT$\n"
+ "฿\n"
+ "TT$\n\n"
+ "$\n"
+ "₴\n"
+ "£\n"
+ "$\n"
+ "$U\n"
+ "лв\n"
+ "Bs\n"
+ "₫\n"
+ "﷼\n"
+ "Z$\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}